Download


You can download the RadioPlayerApp for Windows, Mac and Linux as follows:

Latest Release – Release Candidate – Version 0.9.6

Release notes: Fixed issue for displaying episode images. Fresh compile with latest Air SDK (Much smaller footprint).
Known issues: You may find you need to delete any installed older version before you install this. Also – if anyone spots long periods of ‘hanging’ during start up please comment below.

Download the RadioPlayerApp v0.9.6

Please note that this will download a file – with extension ‘.air’ – if you already have Adobe Air installed – simply double click this file to install. If you haven’t installed Adobe Air already – install it before attempting to run this app.

It should install from there. Any problems – visit the support area.

Alternative download attempt:

Please upgrade your Flash Player This is the content that would be shown if the user does not have Flash Player 9.0.115 or higher installed.

Previous Stable release – Version 0.9.5

Download the RadioPlayerApp v0.9.5

Please note that this will download a file – with extension ‘.air’ – if you already have Adobe Air installed – simply double click this file to install. If you haven’t installed Adobe Air already – install it before attempting to run this app.

It should install from there. Any problems – visit the support area.

Alternative download attempt:

Please upgrade your Flash Player This is the content that would be shown if the user does not have Flash Player 9.0.115 or higher installed.

13 thoughts on “Download”

  1. I’m a linux ubuntu 12.04 user I have Adobe air installed but when I try to install your radio player; that by the way I had previously installed on the same OS but after a reload I got this message

    The application could not be installed because the installer file is damaged. Try obtaining a new installer file from the application author.

    I had saved my previous files radioplayer and set it up to launch without direct install to air 2.6 which I had done previously for my older laptop since air is only an environment this method worked before but not this time, this time I got a message saying radio player could not validate my license check your internet connection and try again. then presents a quit button, is there any reason why it should not install or run?

    1. @DH – I’ve added a AIR installer function on the Download page. Although the app has been built with a minimum of requiring Air 2.6 – it should work on anything newer than that (indeed – I’ve tested it on a few AIR 3.x instances). However – I’m going to take a longer look at the install package as things changed recently with the certificates in Air – so it’s possible there is a problem.

  2. Hope it will work out, I have really enjoyed using the radioplayer app in the past. I recently upgraded to ubuntu 12.10 and installed Air 2.6 but the same thing happened as before, same messages.
    I somehow think its down to Adobe wanting to sqeeze Linux users out which seems a little stupid if you ask me, but when has adobe ever listened to their users.

    I remember when a european company came up with an alternative to their reader. They invited the ceo over for a conference on pdf’s futures and had him arrested for copyright infringment at the airport!

    thats the kind of people Adobe are.

  3. Still not installing with Air 2.6 on ubuntu 12.04 onwards I have it installed on the laptop with 11.04 on it, but no longer supported, which means I will soon lose the radioapp for good when I upgrade soon to 13.04. it’s a shame really that Linux users are frozen out by adobe and app makers.
    Since There is little chance of the maker fixing it for Ubuntu Linux users. I will enjoy it while I can, untill close down, which is April 25 2013 when the new Ubuntu distro 13.04 comes out. Shame about that but I can’t see me spending £100 + on W7 just to get a radio app when everything I work on and do is on totally free Ubuntu.

    However, if you have a sudden change of heart it would be most appreciated.

  4. your player does not work man you need to publish the license properly for it to install on other peoples computers and on different versions of Air.

    it only takes a few clicks for you to do that, quit dropping the ball your dates are screwed up too. you can fix it real easy.

  5. this is the only app in air I can’t install same message from the dowload file or he online install file is damaged

  6. Still the same old message no matter if I use the online installer or the download I’m using Air 2.6 I’ve had no problem with other Air apps just this one even the historically notoriously picky Iplayer desktop from the BBC went in without a hitch.
    The message is…from either download on web install for radioplayer.

    “The application could not be installed because the installer file is damaged. Try obtaining a new installer file from the application author”.

    I’ve tried it on two further laptops and another base set all with the same message. that’s on 2.6 and 3+ all with up to date flash as well.

    1. …and that’s because I hadn’t uploaded the version that I’d repackaged (v.0.9.5). I’ve done this now – so I hope you have success on the Downloads page. Please report back any problems you have.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>